Major outage within our AWS EU Region.
Incident Report for GameSparks
Resolved
Our engineering team has identified the root cause of performance degradation and action has been taken to restore service.

Service has been restored in the AWS EU region.
Posted 6 months ago. Jun 15, 2017 - 16:30 BST
Investigating
Our engineering team has been alerted and are actively investigating the issue.
Posted 6 months ago. Jun 15, 2017 - 15:30 BST